Since it's basically complete now, I figured I'd post something detailing it. Actually, it's been mostly complete for a while now, but the last couple small touches came together this week.

Despite the fact that I got a perfectly capable mini 486 PC earlier this year, I still decided I wanted to build my own similar system in a baby AT form-factor case. This way I could customize it more to my liking. I also really wanted to use a specific style baby AT case that matched the old 386 PC my family used to have. It's nothing special at all, but it's kind of stuck in my head over the years and become synonymous to me with "old DOS PC", so I pretty much was unwilling to let this "requirement" of mine go.

I began picking up parts during the summer and piece by piece I've finally got everything assembled. Strangely enough, getting the particular AT case I wanted was hardest, even though from what I gather it was actually a very common style case back then. Maybe just a coincidence that I had a hard time finding one.

Actually this ended up being the second case of this style that I received. The first one was shipped and arrived broken (the plastic front was cracked and broken in multiple places). Got pretty lucky that I was able to get a second one now that I think of it.

So, what's inside? Let's take a look:

  • CPU: Intel 80486 DX2 SX911 66Mhz
  • Motherboard: FIC 486-PVT, 256KB L2 Cache
  • RAM: 16MB
  • I/O Controller: Promise Technology 560C PDC20630, VLB
  • Graphics: S3 Trio32 2MB, VLB
  • Network: 3Com 3C509B-TPC
  • Sound: Sound Blaster Pro 2.0 CT2600 and Gravis Ultrasound Classic 3.74 1MB
  • Hard Disk: Quantum Maverick ProDrive 540MB 3600RPM MV54A011
  • Floppy Drive: 3.5" 1.44MB Sony MPF920-E and 5.25" 1.2MB Teac FD-55GFR
  • CD-ROM: Torisan 6x CDR-S16
  • Power: Athena Power AP-AT30 300W

Since I ended up getting basically every piece separately, it almost certainly ended up costing a bunch more then it would have if I had bought some pre-assembled PC from eBay or some other place (which people do sell, tested and working, even today). However, given all the trouble I had to go through to get this working, it really feels a lot more satisfying having gone this route.

As one may expect given the era, contrary to building a PC today, a lot of things [i]did not[/i] "just work" together out of the box with this PC. This is especially the case when talking about VESA local bus (VLB) hardware where stability was a common problem. Having to adjust jumpers on the motherboard and the different ISA cards to get the settings just right is quite a different problem from today's PC hardware. This can be even more difficult a task today because for some motherboards the documentation is sparse or even outright missing, leaving you to either have to figure it out by trial and error, or hope the (often limited) labels printed on the motherboard or ISA cards themselves are complete enough and self-explanatory.

Luckily for me, with this particular motherboard I was able to find PDF scans of the original manual. The other card that you'll usually want a manual for due to all the jumpers on it is the I/O controller. In my case, I was unable to find a manual, but the labels printed on the card itself were sufficient enough to get it working properly.

Well, actually, I'm not sure on that last bit to be honest! It did seem to be working perfectly fine up until a week or so ago where I started having problems with the BIOS detecting the hard disk. I thought at first that it might have been an indication that the hard disk I was using was dieing or dead, but after swapping it out for another, using a totally different I/O controller card and also trying different IDE cables, I was unable to eliminate the issue. And to make matters worse the issue only manifested itself sometimes. The only thing I've found so far that solved this problem was to connect all of the IDE devices to the IDE channel that runs on the ISA bus instead of VLB. This isn't too big a deal, as I believe that since I'm running DOS 6.22 primarily that I don't see any benefit whatsoever to having the hard disk running over VLB.

It is worrisome though that the problem only started to occur just recently and seemingly not a result of any other hardware changes (since it had been a while prior that I had made any). Either some other component in this build is starting to become a little flakey, or this is just the fabled VLB stability problems I've heard about rearing it's ugly head. At any rate, something I need to keep an eye on.

Two sound cards probably seems strange at first but there is a reason for both. Sound Blaster is a pretty typical card for the era. The Yamaha OPL chip on this one (and many other Sound Blaster cards) has a pretty recognizable sound that I quite like. And it's compatible with a great many DOS games, so it was an obvious choice.

The Gravis Ultrasound however is something I had never seen before, only heard of, and certainly was not nearly as common a choice at the time. It's an interesting card however, as it was one of the first (if not the first?) sound cards to support hardware mixing of multiple sound sources. Sound Blaster cards couldn't do this, requiring programs to implement their own software mixer which took up valuable CPU resources. In practice, this ended up not really helping many games that supported the Gravis Ultrasound though as almost all of these games supported Sound Blaster too and in an effort to keep the code simpler, would implement their sound engine to the lowest common denominator. This meant not utilizing the Gravis Ultrasounds hardware mixing support since no other card had it.

However, what I really wanted a Gravis Ultrasound for was for it's subjectively better sounding FM synthesis / MIDI playback. So far every game I've compared that supports both Sound Blaster and Gravis Ultrasound sounds better (to me) when configured to use the latter. In some cases, such as with One Must Fall 2097, the difference is objectively better.

For a 486 computer, VESA local bus graphics are pretty unique, and until PCI came around (which was quite soon after VLB was introduced), it provided the fastest graphics you could get. To me, it feels almost necessary to use VLB with a 486 machine since you cannot use VLB with anything else. Everything beyond this hardware level would be PCI and eventually AGP. Everything before, ISA. Using an S3 card is a pretty solid choice. All benchmarks I've seen and done personally have them as top-tier cards of the era. Compatibility is also excellent. Probably a more common choice would've been a Cirrus Logic card though.

Nothing much else to say really. A 6x CD-ROM feels mostly right, maybe a little bit fast for the era? I remember we had a double-speed CD-ROM in my family's 386. A 500MB hard disk is also quite large for a DOS PC really. It's funny to think of that, but then again, I remember my family's 386 had a 20MB hard disk and at the time I thought that was large! 16MB of RAM is plenty for a 486. Most DOS games would need less then 8MB of RAM, so 16MB is nice to have the option for running SMARTDRV, or using a RAM drive, etc. My DJGPP boot configuration sets up both and it makes a significant difference with compile times, still leaving 8MB of RAM free for everything else.